Subtitle Edit, debian 10 and Arabic UTF 8 dilemma

1 post in this topic

Posted

Hello everybody

I'm  newly linux converter, a decision that should be taken years ago , only had the courage to take it 10 days ago.. So far so good. a lot of learning but it's ok , everything is better, except with subtitle edit , my preferable subtitle program that I've been using in windows for years

I have debian 10 , wine and mono complete installed , I tried the portable version with mono , that give me a problem that I'll describe a few lines later, so I decided to try wine and the windows executable version . I used wine to install another windows program (idm) and everything went ok.. when I tried to install Subititle Edit installation went ok , but the program didn't start, it gave me the error in the attached text, I have to stick with mono then.

The problem is I can't get it to work with arabic subtitles ,,it doesn't even show letters , boxes or anything for that matter, and when I choose to export the subtitle (that I cannot even see) as sup it shows arabic letters but not correctly rendered 

I spent hours searching for a solution , either to the errors given by wine or to the arabic rendering problem with mono.. obviously didn't find a solution. learned about locales and tried many fonts,no avail 

 

please forgive me if the solution was obvious , or if it was a known bug in mono, wine or subtitle edit,, just tell me that I don't have to revert to the "you know which" OS just to use Subtitle Edit :)

 

backtrace.txt

Screenshot from 2019-12-01 13-52-49.png

Screenshot from 2019-12-01 13-52-12.png

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Member Statistics

    20,819
    Total Members
    6,268
    Most Online
    Newest Member
    Napressao
    Joined 12/07/2019 11:37 AM