Jump to content
Sub-Talk.net - TV shows community
Sign in to follow this  

Subtitle Edit...generated Waveform Out Of Sync With Speech And Sounds

Recommended Posts


Have been using Subtitle edit successfully for about a month now, and it has done a great job on 36 episodes of Un village francais that I am translating into English .


But on the latest episode that I'm working on, Series 5 Episode 1, the waveform I generated gradually becomes out of sync with the sound.


The actual sound  matches the lip movements, doors slamming etc  on-screen, so there doesn't seem to be  a problem with the film.


At the beginning of the episode, the waveform matches the sound, but it gradually falls out of sync. At the end of the episode ( about 45 minutes), the waveform cursor leads the actual sounds by 1.5 seconds.


This makes visual subtitle syncing a lot more difficult.


It hasn't happened on the previous 36 episodes and doesn't appear to be a problem on the remaining 11.


Any ideas on why ?  Can it be corrected ?   

Share this post

Link to post
Share on other sites

Hi Rod,


wave extraction with VLC normally works, but I have seen a few files where the sync failed... it's worth a try to download FFMPEG and switch to use FFMPEG for wave form extraction (SE -> Options -> Settings -> Wave form). FFMPEG can handle a few more formats than VLC

Share this post

Link to post
Share on other sites
Gam TM

I had the same issue, maybe due to the fact that my movie consists in fact of many segments that were put together by a certain software...

But I found a way to synchronize the SE generated waveform with audio. First of all, please note the initial situation on SE main screen: the video have a length of 00:20:08.438 and the generated waveform is only 00:20:03.653.

Here it is how I did:

1.  I located the waveform on my PC in C:\Users\myuser\AppData\Roaming\Subtitle Edit\Waveforms, filename is 927f8e9f40b6b853.wav

2. I used Audacity software with its function "change speed":

a) open file 927f8e9f40b6b853.wav in Audacity

b) select entire file CTRL+A

c) use Effect/Change speed

d) enter as New Lenght: 00:20:08.438  (I noted that it accepts only 00:20:08.440, but this is acceptable).

e) export the resulting as .wav type file, in the same folder of SE waveforms.

Then it is necessary to reopen the .srt file in SE in order the new waveform to be loaded.


  • Like 1

Share this post

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Member Statistics

    Total Members
    Most Online
    Newest Member
  • Create New...