Stripping font tags from embedded subs with Subtitle Edit

4 posts in this topic

Posted

Can someone walk me through how to strip 

<font color="#ffffff"></font>

tags from embedded fonts in .mp4 files with Subtitle Edit?

I think it's just a simple Find/Replace operation and then resync if needed but when I open the file in SE, it appears that the final few minutes of the subs are missing, tags and all.

Share this post


Link to post
Share on other sites

Posted

Hi, @MangJD.

Subtitle Edit has a function for that:

It removes all tags though. Including italics and music notes if there are any.

There can be other tags used as well, such as:

<span style="color:white;"></span>

That one is not handled by the "remove formatting" function. So the search & replace one is necessary.

Is your sub incomplete from start or only after removing the tags?

Share this post


Link to post
Share on other sites

Posted

 

Is your sub incomplete from start or only after removing the tags?

Thank you, kinglouisxx, I have appreciated your work for years now.

From the start. It is incomplete from the point of import (but complete in the video file).

Share this post


Link to post
Share on other sites

Posted

From the start. It is incomplete from the point of import (but complete in the video file).

Sent you a PM for details.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Member Statistics

    20,056
    Total Members
    2,516
    Most Online
    Newest Member
    samuel zimmerman
    Joined 05/20/2018 11:55 AM